My Astronomy

Latest History of Astronomy Weekly 

Latest ANS Weekly

 


My New Book May 2018My previous e-book
 

ABOUT THE WEBSITE - CLICK HERE

My Telescopes

My Main Telescope - C14 and Paramount ME

My new Paramount MyT and 8-inch Ritchey-Chretien Telescope

MyT Hand Controller

My Meade 12 inch SCT on a CGEM (Classic) Mount

My 4 inch Meade Refractor with Sky Watcher Guidescope and ZWO camera on a CGEM (Classic) Mount

Skywatcher Star Adventurer Mount with Canon 40D

 

My Solar setup using a DSLR and Mylar Filter on my ETX90

DSLR attached to ETX90. LiveView image of 2015 partial eclipse on Canon 40D

Astronomy Blog Index
About the Site

 I try to log my observing and related activities in a regular blog - sometimes there will be a delay but I usually catch up. An index of all my blogs is on the main menu at the top of the page with daily, weekly or monthly views. My Twitter feed is below. I am also interested in photograping wildlife when I can and there is a menu option above to look at some of my images. I try to keep the news feeds from relevant astronomical sources up to date and you will need to scroll down to find these.

The Celestron 14 is mounted on a Paramount ME that I have been using for about 10 years now - you can see that it is mounted on a tripod so is a portable set up. I still manage to transport it on my own and set it all up even though I have just turned 70! It will run for hours centering galaxies in the 12 minute field even when tripod mounted.

 

My Recent Tweets
« Day 105 Saturday 5th July 2014 The Paramount ME problem. | Main | Day 103 Thursday 3rd July 2014 Spain and Australia Pluto Images compared. »
Friday
Jul042014

Day 104 Friday 4th July 2014 C14 out of action.

The problem persisted and I was unable to start up the mount so I posted a description of the problem in the Paramount ME forum at Software Bisque which is normally answered fairly promptly by one of the Bisque brothers based in Boulder Colorado. I did realise it was 4th July so I don't expect a response until next week. I decided to strip down the telescope - removing the C14 and the balance weights. This had no effect at all - the mount on its own without load had the same problem.

The other day I installed the polar finderscope for the CGEM. This video shows the installation (from Mark Zabokrtsky on You Tube). My finderscope does not have the metal ring.